Get in touch
Back
Maintenance

CS:GO servers under maintenance

Completed 9 Jun at 05:00pm CEST.

SUREAX ARENA 1V1 SUREAX DEATHMATCH
Completed

Maintenance completed

Posted 9 Jun at 05:00pm CEST.
Started

CS:GO servers will go down, during that time, we will update arena 1v1 maps and build DM server entirely from scratch.

Posted 9 Jun at 03:00pm CEST.